Ahui Writes Word
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2562 Accepted Submission(s): 931
Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
Output
Output the maximum value in a single line for each test case.
Sample Input
5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5
Sample Output
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
0-1背包超时、转多重背包、从0-1背包转多重背包
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[1000000];
int wupin[11][11];
int v,n;
void zoreonepack(int val,int cost)
{
for(int i=v;i>=cost;i--)
{
if(dp[i-cost]+val>dp[i])
{
dp[i]=dp[i-cost]+val;
}
}
}
void completepack(int val,int cost)
{
for(int i=cost;i<=v;i++)
{
dp[i]=max(dp[i],dp[i-cost]+val);
}
}
void multipack(int val,int cost,int num)
{
if(num*cost>=v)
{
completepack(val,cost);
}
else
{
int k=1;
while(k<num)
{
zoreonepack(k*val,k*cost);
num-=k;k+=k;
}
zoreonepack(num*val,num*cost);
}
}
int main()
{
while(~scanf("%d%d",&n,&v))
{
memset(dp,0,sizeof(dp));
memset(wupin,0,sizeof(wupin));
for(int i=0;i<n;i++)
{
char s[1000];
int x,y;
scanf("%s%d%d",s,&x,&y);
wupin[x][y]++;
}
for(int i=0;i<11;i++)
{
for(int j=0;j<11;j++)
{
if(wupin[i][j]!=0)
{
multipack(i,j,wupin[i][j]);
}
}
}
printf("%d\n",dp[v]);
}
}