POJ 2406 Power String

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////分析:

KMP。理解了KMP中的next数组就很好理解这题的实现了。分析可以知道num=len/(len-next[len]):

代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char B[1000005];
int nxt[1000005];
void makenext(int m)
{
    int l,r;
    l=-1;r=0;nxt[0]=-1;
    while(r<=m){
        if(l==-1||B[l]==B[r]){
            nxt[++r]=++l;
        }else{
            l=nxt[l];
        }
    }
}

int main()
{
   // freopen("in.txt","r",stdin);
    while(~scanf("%s",B)){
        if(!strcmp(B,"."))break;
        int len,ans;
        len=strlen(B);
        makenext(len);
        if(len%(len-nxt[len])==0)
            printf("%d\n",len/(len-nxt[len]));
        else printf("1\n");

    }
    return 0;
}


你可能感兴趣的:(算法,ACM,poj)