杭电ACM HDU 1020 Encoding

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18738    Accepted Submission(s): 8076


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 


 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 


 

Output
For each test case, output the encoded string in a line.
 


 

Sample Input
   
   
   
   
2 ABC ABBCCC
 


 

Sample Output
   
   
   
   
ABC A2B3C
 


 

Author
ZHANG Zheng
 


 

Recommend
JGShining

 

#include <cstdio>
#include <string.h>
int main(){
    int t;
    char str[10001];
    scanf("%d",&t);
    while(t--){
        scanf("%s",str);
        int count=1;
        for(int i=0;i<strlen(str);i++){
            if(str[i]==str[i+1])count++;
            else{
                if(count==1) printf("%c",str[i]);
                else printf("%d%c",count,str[i]);
                count=1;
            }
        }
        printf("\n");
    }
}


 

 

你可能感兴趣的:(杭电ACM HDU 1020 Encoding)