DNA Sorting
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 88585 |
|
Accepted: 35595 |
Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
Source
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
char s[55];
int sum;
}que[110];
bool cmp(node x,node y)
{
return x.sum<y.sum;
}
int main()
{
int m,n;
while(cin>>n>>m)
{
memset(que,0,sizeof(que));
for(int i=0;i<m;i++)
{
cin>>que[i].s;
for(int j=0;j<n-1;j++)
{
for(int k=j+1;k<n;k++)
{
if(que[i].s[k]<que[i].s[j])
{
que[i].sum++;
}
}
}
}
sort(que,que+m,cmp);
for(int i=0;i<m;i++)
{
cout<<que[i].s<<endl;
}
}
return 0;
}
求逆序数从小到达排列;