POJ3176 简单DP....

POJ3176

应该是目前为止做过最简单的DP题了,题意就是一个类似三角形的格子,每一个格子有自己的权值,问从顶点出发走到底最大的权值有多少。设dp[i][j]为走到行i,列为j获得的最大值,自底向上走,则有转移方程dp[i][j] = max(dp[i]]j]+dp[i+1][j],dp[i][j]+dp[i+1][j+1]),最后dp[1][1]即为结果(从1开始记录)

Description

The cows don’t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving “down” to one of the two diagonally adjacent cows until the “bottom” row is reached. The cow’s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

int dp[355][355];

int main()
{
    int n;
    scanf("%d",&n);
    for (int i = 1;i<=n;i++)
      for (int j = 1;j<=i;j++)
         scanf("%d",&dp[i][j]);

    for (int i = n-1;i>=1;i--)
        for (int j = 1;j<=i;j++)
          dp[i][j] = max(dp[i+1][j]+dp[i][j],dp[i][j]+dp[i+1][j+1]);
    printf("%d\n",dp[1][1]);
}

你可能感兴趣的:(POJ3176 简单DP....)