HDU 2830 移动的矩阵 (思维题)


Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.
 

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 

Output
Output one line for each test case, indicating the maximum possible goodness.
 

Sample Input
   
   
   
   
3 4 1011 1001 0001 3 4 1010 1001 0001
 

Sample Output
   
   
   
   
4 2 Note: Huge Input, scanf() is recommended.
 


找下规律... 将图像抽象一下。


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int a[1111][1111],pre[1111][1111],h[1111];
char s[1111][1111];
int main()
{
	int n,m,k,tem,ans;
	int i,j;
	while(scanf("%d%d",&n,&m)!=EOF) {
		for(i=1;i<=n;i++) scanf("%s",s[i]);
		for(i=1;i<=n;i++) {
			for(j=0;j<m;j++){
				a[i][j+1]=s[i][j]-'0';
				pre[i][j+1]=0;
			}
		}
		for(j=1;j<=m;j++) {
			for(i=1;i<=n;i++) {
				if(a[i][j]) pre[i][j]=pre[i-1][j]+1;
			}
		}
		ans=0;
		for(i=1;i<=n;i++) {
			for(j=1;j<=m;j++) {
				h[pre[i][j]]++;
			}
			tem=0;
			for(k=i;k;k--) {
				ans=max(ans,k*(tem+h[k]));
				tem+=h[k];	
			}
			for(k=1;k<=i;k++) h[k]=0;
		}
		printf("%d\n",ans);
		
	}
	return 0;
}




你可能感兴趣的:(HDU 2830 移动的矩阵 (思维题))