POJ3268 求最长路径(一来一回)

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 16180   Accepted: 7393

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2.. M+1: Line  i+1 describes road  i with three space-separated integers:  AiBi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

Source

USACO 2007 February Silver

#include<stdio.h>
#include<string.h>
#define inf 0xffffff
int mp[1020][1020];
int visit[1020];
int dis[1020];
int disb[1020];
int n,m,x;
void suan()
{
    int i,j,k;
    int mincost;


    memset(visit,0,sizeof(visit));//v函数判断有没有访问过。。。其实自己也不太懂QAQ
    for(int i=1; i<=n; i++)//cost[i]函数表示1到i的最短距离
    {
        dis[i]=mp[x][i];
        disb[i]=mp[i][x];
    }
    for(i=1; i<=n; i++)//不断更新吧。QAQ
    {
        mincost=inf;
        for(j=1; j<=n; j++)//先找出一个1到k(j)的最短距离
        {
            if(!visit[j]&&mincost>dis[j])
            {
                mincost=dis[j];
                k=j;
            }
        }

        visit[k]=1;
        for(j=1; j<=n; j++)//对于新的j,如果刚才的最短路(1到k)+k到j的距离比直接从1到j要段,那么1到j的最短距离就更新为1到k再到j的距离
        {
            if(!visit[j]&&dis[j]>dis[k]+mp[k][j])
            {
                dis[j]=dis[k]+mp[k][j];
            }
        }

    }
    memset(visit,0,sizeof(visit));//其实不明白这个大循环是什么意思QAQ。。。。。。。。。
    for(i=1; i<=n; i++)//不断更新吧。QAQ
    {
        mincost=inf;
        for(j=1; j<=n; j++)//先找出一个1到k(j)的最短距离
        {
            if(!visit[j]&&mincost>disb[j])
            {
                mincost=disb[j];
                k=j;
            }
        }

        visit[k]=1;
        for(j=1; j<=n; j++)//对于新的j,如果刚才的最短路(1到k)+k到j的距离比直接从1到j要段,那么1到j的最短距离就更新为1到k再到j的距离
        {
            if(!visit[j]&&disb[j]>disb[k]+mp[j][k])
            {
                disb[j]=disb[k]+mp[j][k];
            }
        }

    }
   mincost=-1;
    for(i=1; i<=n; i++)
    {
        if(dis[i]+disb[i]>mincost)
            mincost=dis[i]+disb[i];
    }
    printf("%d\n",mincost);
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&x)!=EOF)
    {
        memset(visit,0,sizeof(visit));
        for(int  i=1; i<=n; i++)
            for(int j=1; j<=n; j++)
            {
                if(i==j)
                    mp[i][j]=0;
                else mp[i][j]=inf;
            }
        while(m--)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            mp[a][b]=c;
        }
        suan();

    }
}



你可能感兴趣的:(POJ3268 求最长路径(一来一回))