HDU 3853 LOOPS

LOOPS

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 125536/65536 K (Java/Others)
Total Submission(s): 3541    Accepted Submission(s): 1426


Problem Description
Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.
HDU 3853 LOOPS_第1张图片
The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!
At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS.




 

Input
The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF


 

Output
A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.

 

Sample Input
   
   
   
   
2 2 0.00 0.50 0.50 0.50 0.00 0.50 0.50 0.50 0.00 1.00 0.00 0.00
 

Sample Output
   
   
   
   
6.000
 

Source
2011 Invitational Contest Host by BUPT
 

概率DP。

在做这题之前我并不是很明白“正向推概率,反向推期望”这句话。

现在明白了。当p0=1的时候,此时期望是已知的dp[i][j]=0;

然后用此时的dp状态去向前推那些p0不为一的,直到结束。

最后dp[0][0]保存的就是所求的期望。

其实这是一个逆推的过程。

转移方程便如代码所示。

dp[i][j]=p0[i][j]==1?0:(p0[i][j]*2+p1[i][j]*(dp[i][j+1]+2)+p2[i][j]*(dp[i+1][j]+2))/(1-p0[i][j]);

后面那个长长的式子是这样推出来的。

在大牛的博客上看到这样一句话。期望=sum((期望+实验结果)*概率)

这里的实验结果就是单次消耗的魔法值2。


#include <stdio.h>
#define N 1005
double p0[N][N],p1[N][N],p2[N][N],dp[N][N];
int main()
{
        int r,c;
        while(scanf("%d%d",&r,&c)>0)
        {
                for(int i=0;i<r;i++)
                        for(int j=0;j<c;j++)
                                scanf("%lf%lf%lf",&p0[i][j],&p1[i][j],&p2[i][j]);
                for(int i=r-1;i>=0;i--)
                        for(int j=c-1;j>=0;j--)
                                dp[i][j]=p0[i][j]==1?0:(p0[i][j]*2+p1[i][j]*(dp[i][j+1]+2)+p2[i][j]*(dp[i+1][j]+2))/(1-p0[i][j]);
                printf("%.3lf\n",dp[0][0]);
        }
        return 0;
}


 

你可能感兴趣的:(HDU 3853 LOOPS)