Elevator
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60716 Accepted Submission(s): 33314
Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
Sample Output
Author
ZHENG, Jianqiang
Source
ZJCPC2004
Recommend
JGShining | We have carefully selected several similar problems for you: 1005 1108 1061 1049 1013
Statistic | Submit | Discuss | Note
非常简单的模拟题 读懂题意就好了
题意:按照题目给的楼层号顺序 停电梯 往上升耗时6s 往下降耗时4s 楼层停5s
#include <stdio.h>
int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
int sum=0;
int current=0;
for(int i=0;i<n;i++)
{
int x;
scanf("%d",&x);
if(x>current)
{
sum+=6*(x-current)+5;
}
else
{
sum+=4*(current-x)+5;
}
current=x;
}
printf("%d\n",sum);
}
return 0;
}