[poj 2352] Stars 树状数组

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40003 Accepted: 17365

Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source
Ural Collegiate Programming Contest 1999

题目链接:http://poj.org/problem?id=2352

题意:在坐标上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level x

按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。

思路:y是升序给出,所以按x建树状数组,i的lev=get(i.x);
*!!注意
0的low_bit=0;
故i++;
代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int C[32005];
int aa,bb;
int n;
int lev[32005];
void add(int x)
{  
      while(x<=32005)//!
      {  
        ++C[x];  
        x += x&(-x);  
      }  
}  
int _get(int x)
{
    int ret=0;
    while(x>0)
    {
        ret+=C[x];
        x-=x&(-x);
    }
    return ret;
}
int main()
{
    scanf("%d",&n);

    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&aa,&bb);
        aa++;//!!!
        add(aa);
        lev[_get(aa)]++;


    }
    for(int i=1;i<=n;i++)
    printf("%d\n",lev[i]);

}

你可能感兴趣的:(poj)