hdu2955 0-1背包变形 抢银行

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9938    Accepted Submission(s): 3705


Problem Description
The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

hdu2955 0-1背包变形 抢银行_第1张图片
For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.
 

Input
The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj . 
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .
 

Output
For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.
 

Sample Input
   
   
   
   
3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05
 

Sample Output
   
   
   
   
2 4 6
 
题目大意:
以最小被抓的概率强最多的钱
输入0.04 0.02 0.03为被抓的概率 
这个题不是认为题目所给的浮点型的数据都是精确到小数点后两位,然后把概率放大100倍,转换成为熟悉的01背包;而是转换成求最大逃跑概率下抢最多的钱,因为只有这样逃跑的概率能直接相乘(对立事件)。
另dp[i]表示抢了i元钱逃跑的概率;
则对应的状态转移方程可写为:

dp[j]=max(dp[j], dp[j-v[i]]*w[i]) 

v[i]为每家银行的钱数,w[i]为抢这家银行逃跑的概率。
抢劫的金额为0时,肯定是安全的,所以dp[0]=1;其他金额初始为最危险的所以概率全为0

#include<iostream>
#include<cstring>
#include<math.h>
#include<algorithm>
using namespace std;
double dp[500005];int v[1005];
double  w[1005];
int main()
{
	int n;
	cin>>n;
	while(n--)
	{
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		int i,a,j,sum=0;
		double p;
		cin>>p>>a;
		p=1-p;
		for(i=1;i<=a;++i)
		{
			cin>>v[i]>>w[i];
			w[i]=1-w[i];
			sum+=v[i];
		}
		for(i=1;i<=a;++i)
		{
			for(j=sum;j>=v[i];--j)
			{
				dp[j]=max(dp[j-v[i]]*w[i],dp[j]); 
			}		
		}
		for(i=sum;i>=0;--i)
			if(dp[i]>p)
			{
				cout<<i<<endl;
				break;
			}
	}
}


你可能感兴趣的:(hdu2955 0-1背包变形 抢银行)