Reward
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5701 Accepted Submission(s): 1730
Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
Sample Output
1777
-1
#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
struct zz
{
int to;
int next;
}p[51000];
int in[51000];
int head[51000];
int num[51000];
void topo(int n)
{
queue<int>q;
int i,j,k;
int ans=0;
int sum=0;
for(i=1;i<=n;i++)
{
if(in[i]==0)
q.push(i);
}
while(!q.empty())
{
k=q.front();
q.pop();
ans++;
for(j=head[k];j!=-1;j=p[j].next)
{
in[p[j].to]--;
if(in[p[j].to]==0)
{
q.push(p[j].to);
num[p[j].to]=num[k]+1;
}
}
}
for(i=1;i<=n;i++)
sum+=num[i];
if(ans!=n)
printf("-1\n");
else
printf("%d\n",sum);
}
int main(){
int n,m,i,j,a,b;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(in,0,sizeof(in));
memset(head,-1,sizeof(head));
for(i=1;i<=n;i++)
num[i]=888;
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
p[i].to=a;
p[i].next=head[b];
head[b]=i;
in[a]++;
}
topo(n);
}
return 0;
}
//大神的代码
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
int n,m;
int indegree[10010];
struct Node{
int to;
int next;
}A[20010];
int head[10010];
int value[10010];
void INPUT()
{
int i,j,a,b;
memset(head,-1,sizeof(head));
memset(indegree,0,sizeof(indegree));
for(i=0;i<m;++i)
{
scanf("%d%d",&a,&b);
A[i].to=a;
A[i].next=head[b];
head[b]=i;
indegree[a]++;
}
}
void Topo(){
int i,j;
queue<int>Q;
for(i=1;i<=n;++i)
{
value[i]=888;
if(indegree[i]==0)
{
Q.push(i);
}
}
int top,money=0,ans=0;
while(!Q.empty())
{
ans++;
top=Q.front();Q.pop();
indegree[top]=-1;
money+=value[top];
for(int k=head[top];k!=-1;k=A[k].next)
{
indegree[A[k].to]--;
if(indegree[A[k].to]==0)
{
Q.push(A[k].to);
}
value[A[k].to]=value[top]+1;
}
}
if(ans==n)
printf("%d\n",money);
else
printf("-1\n");
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
INPUT();
Topo();
}
return 0;
}