hdoj ZYB's Biology 5590 (字符串) 水

ZYB's Biology

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 85    Accepted Submission(s): 69


Problem Description
After getting 600 scores in NOIP ZYB(ZJ267) begins to work with biological questions.Now he give you a simple biological questions:
he gives you a DNA sequence and a RNA sequence,then he asks you whether the DNA sequence and the RNA sequence are
matched.

The DNA sequence is a string consisted of A,C,G,T ;The RNA sequence is a string consisted of A,C,G,U .

DNA sequence and RNA sequence are matched if and only if A matches U , T matches A , C matches G , G matches C on each position.

Input
In the first line there is the testcase T .

For each teatcase:

In the first line there is one number N .

In the next line there is a string of length N ,describe the DNA sequence.

In the third line there is a string of length N ,describe the RNA sequence.

1T10 , 1N100

Output
For each testcase,print YES or NO ,describe whether the two arrays are matched.

Sample Input
   
   
   
   
2 4 ACGT UGCA 4 ACGT ACGU

Sample Output
   
   
   
   
YES NO
#include<stdio.h>
#include<string.h>
#include<algorithm>
#define N 110
using namespace std;
char a[N];
char b[N];
int main()
{
	int t,n;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		scanf("%s%s",a,b);
		for(i=0;i<n;i++)
		{
			if(a[i]=='A') a[i]='U';
			else if(a[i]=='T')	a[i]='A';
			else if(a[i]=='C')	a[i]='G';
			else if(a[i]=='G')	a[i]='C';
		}
		if(strcmp(a,b)==0)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

 

你可能感兴趣的:(hdoj ZYB's Biology 5590 (字符串) 水)