trie 字典树

http://acm.hdu.edu.cn/showproblem.php?pid=1671


Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14466    Accepted Submission(s): 4871


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
   
   
   
   
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
   
   
   
   
NO YES
 


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define MAX 10
using namespace std;
bool flag;

typedef struct Trie_Node
{
    bool isphone;
     Trie_Node *next[MAX];
     Trie_Node ()
     {
         memset(next,NULL,sizeof(next));
         isphone=false;
     }
}Trie;

void insert(Trie *root,char *phone)
{
    Trie *p=root;
    while(*phone!='\0')
    {
        if(p->next[*phone-'0']==NULL)
        p->next[*phone-'0']=new Trie_Node();///build new jie dian
        
        if(p->isphone==true)
            flag=true;
        p=p->next[*phone-'0'];
        phone++;
    }
    p->isphone=true;
    for(int i=0;i<MAX;i++)
    {
        if(p->next[i]!=NULL)
        {
            flag=true;
            break;
        }
    }
}

void del(Trie *root)///释放空间
{
    for(int i=0;i<MAX;i++)
    {
        if(root->next[i]!=NULL)
        {
            del(root->next[i]);
        }
    }
    free(root);
}

int main(int argc, char *argv[])
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int i;
        int n;
        char phone[11];
        Trie *root=(Trie *)malloc(sizeof(Trie));
        root->isphone=false;
        flag=false;
        for(i=0;i<MAX;i++)
        {
            root->next[i]=NULL;
        }
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",phone);
            if(flag!=true)
            {
                insert(root,phone);
            }
        }
        if(flag==true)
            printf("NO\n");
        else
            printf("YES\n");
        del(root);               //必须释放空间,否则会报Memory Limited的错误
    }
    return 0;
}


你可能感兴趣的:(trie 字典树)