uva 100 The 3n + 1 problem (递归)

 The 3n + 1 problem 

Background

Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

The Problem

Consider the following algorithm:

 
		1. 		 input n

2. print n

3. if n = 1 then STOP

4. if n is odd then

5. else

6. GOTO 2

Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers nsuch that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

The Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

You can assume that no operation overflows a 32-bit integer.

The Output

For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

Sample Input

1 10
100 200
201 210
900 1000

Sample Output

1 10 20
100 200 125
201 210 89
900 1000 174
题目大意:前提,一个数字n,如果n为奇数,n  = 3 * n + 1,如果n 为偶数, n = n / 2.直到n = 1为止,中间出现过的n的不同个数,成为cycle length,给出一个范围,前后大小不限,求a~b之间数的cycle length的最大值,输出这个最大值。

解题思路:用递归模拟算式。

#include <stdio.h>
int handle(int k){
	if (k == 1)
		return 1;
	else if (k % 2)
		return handle(3 * k + 1) + 1;
	else
		return handle(k / 2) + 1;
}

int main(){
	int n, m;
	while (~scanf("%d%d", &n, &m)){
		int min = n < m? n: m;
		int max = n > m? n: m;
		int cnt = 0, t;
		for (int i = min; i <= max; i++){
			t = handle(i);
			if (t > cnt)
				cnt = t;
		}

		printf("%d %d %d\n", n, m, cnt);
	}
	return 0;}

你可能感兴趣的:(uva 100 The 3n + 1 problem (递归))