【codevs1869】硬币购物,背包+神奇的容斥原理

硬币购物 2008年
时间限制: 1 s
空间限制: 256000 KB
题目等级 : 大师 Master
题解
题目描述 Description
一共有4种硬币。面值分别为c1,c2,c3,c4。某人去商店买东西,去了tot次。 每次带di枚ci硬币,买si的价值的东西。请问每次有多少种付款方法。

输入描述 Input Description
第一行 c1,c2,c3,c4,tot 下面tot行 d1,d2,d3,d4,s

输出描述 Output Description
每次的方法数

样例输入 Sample Input
1 2 5 10 2
3 2 3 1 10
1000 2 2 2 900

样例输出 Sample Output
4
27

数据范围及提示 Data Size & Hint

di,s<=100000
tot<=1000
写在前面:未知的知识可以把普通人遍体鳞伤,也可以让天才秀高智商,而我属于前者

思路:大家还是去看别人写的吧
代码:

#include<cstdio>
#include<cstring>
#include<iostream> 
#include "algorithm"
#define LL long long 
using namespace std;
int c[5],tot,d[5],s;
LL f[100010]={1};
inline LL re(int x){return c[x]*(d[x]+1);}
main()
{
    for (int i=1;i<=4;i++) scanf("%d",&c[i]);
    scanf("%d",&tot);
    for (int i=1;i<=4;i++)
    for (int j=c[i];j<=100000;j++)
    f[j]+=f[j-c[i]];
    while (tot--)
    {
        for (int i=1;i<=4;i++) scanf("%d",&d[i]);
        scanf("%d",&s);
        long long ans=f[s];
        for (int i=1;i<=4;i++) 
        if (s-re(i)>=0) ans-=f[s-re(i)];
        for (int i=1;i<=3;i++)
        for (int j=i+1;j<=4;j++)
        if (s-re(i)-re(j)>=0) ans+=f[s-re(i)-re(j)];
        for (int i=1;i<=2;i++)
        for (int j=i+1;j<=3;j++)
        for (int k=j+1;k<=4;k++)
        if (s-re(i)-re(j)-re(k)>=0) ans-=f[s-re(i)-re(j)-re(k)];
        if (s-re(1)-re(2)-re(3)-re(4)>=0) ans-=f[s-re(1)-re(2)-re(3)-re(4)];
        printf("%lld\n",ans);
    }
}

你可能感兴趣的:(【codevs1869】硬币购物,背包+神奇的容斥原理)