HDU1241 油田合并(DFS)

点击打开链接

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9572    Accepted Submission(s): 5613


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
   
   
   
   
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
   
   
   
   
0 1 2 2
 
#include <iostream>
#include <cstdio>
#include <cstring>
#define N 100
using namespace std;
char a[N][N];
int n,m;
int dx[8]={0,0,1,1,1,-1,-1,-1};
int dy[8]={1,-1,0,-1,1,0,1,-1};//根据题目自己定义八个方向,有时候是定义四个方向 根据题目意思决定,此种类型题目都需自己定义方向
void dfs(int x,int y)
{
    int tempx,tempy;
    for(int i=0;i<8;i++)
    {
        tempx=x+dx[i];
        tempy=y+dy[i];
        if(tempx>=0&&tempy>=0&&tempx<n&&tempy<m&&a[tempx][tempy]=='@')//确定满足条件时进行搜索,否则跳出
        {
            a[tempx][tempy]='*';
            dfs(tempx,tempy);
        }
        else
            continue;
    }
}
int main()
{
    int count;
    while(cin>>n>>m,n!=0,m!=0)
    {
        count=0;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                if(a[i][j]=='@')
                {
                    count++;
                    dfs(i,j);
                }
            }
        }
        cout<<count<<endl;
    }
    return 0;
}


你可能感兴趣的:(HDU1241 油田合并(DFS))