hdoj5645DZY Loves Balls

Problem Description
DZY loves playing balls.

He has  n  balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it  A . Next, without putting  A  back into the box, he randomly picks another ball from the box, and names it  B .

If the number written on  A  is strictly greater than the number on  B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains  t  denoting the number of testcases.

t  testcases follow. In each testcase, first line contains  n , second line contains  n  space-separated positive integers  ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )
 

Output
For each testcase, output a real number with 6 decimal places. 
 

Sample Input
   
   
   
   
2 3 1 2 3 3 100 100 100
 
Sample Output
   
   
   
   
0.500000 0.000000
 代码:
#include<stdio.h>
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int i,j,a[9999];
		for(i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		double sum;
		sum=n*(n-1);
		double ans=0;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(a[j]>a[i])
				ans++;
			}
		}
		double p;
		p=ans/sum;
		printf("%.6lf\n",p);
	}
	return 0;
}
思路:签到水题。

你可能感兴趣的:(hdoj5645DZY Loves Balls)