hdu2043

密码

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 43276    Accepted Submission(s): 17400


Problem Description

网上流传一句话:"常在网上飘啊,哪能不挨刀啊~"。其实要想能安安心心地上网其实也不难,学点安全知识就可以。

首先,我们就要设置一个安全的密码。那什么样的密码才叫安全的呢?一般来说一个比较安全的密码至少应该满足下面两个条件:

(1).密码长度大于等于8,且不要超过16。
(2).密码中的字符应该来自下面“字符类别”中四组中的至少三组。

这四个字符类别分别为:
1.大写字母:A,B,C...Z;
2.小写字母:a,b,c...z;
3.数字:0,1,2...9;
4.特殊符号:~,!,@,#,$,%,^;

给你一个密码,你的任务就是判断它是不是一个安全的密码。
 

Input
输入数据第一行包含一个数M,接下有M行,每行一个密码(长度最大可能为50),密码仅包括上面的四类字符。
 

Output
对于每个测试实例,判断这个密码是不是一个安全的密码,是的话输出YES,否则输出NO。
 

Sample Input
   
   
   
   
3 a1b2c3d4 Linle@ACM ^~^@^@!%
 

Sample Output
   
   
   
   
NO YES NO
 


遇到的问题和解题思路:

       表示因为strlen是没有算上’\0‘的这点忘了,然后一直判断的时候用的是17和9,所以wa。

       水题。


给出代码:


#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
 using namespace std; bool indexx[4]; char pend[60]; int main(){ int n;
    scanf("%d",&n);
    getchar(); while(n--){
        memset(indexx,0,sizeof(indexx));
        scanf("%s",pend); int count1 = 0;
        //printf("%s\n",pend);
 for(int i = 0;i < strlen(pend);i++){ if(pend[i] >= 'a'&&pend[i] <= 'z')indexx[0] = true; else if(pend[i] >= 'A'&&pend[i] <= 'Z')indexx[1] = true; else if(pend[i] >= '1'&&pend[i] <= '9')indexx[2] = true; else if(pend[i] == '~'||pend[i] == '@'||pend[i] == '#'||pend[i] == '$' ||pend[i] == '%' ||pend[i] == '^')indexx[3]=true; } for(int i = 0;i < 4;i++){ if(indexx[i])count1++; } if(count1 >= 3&&strlen(pend)<=16&&strlen(pend)>=8)printf("YES\n"); else printf("NO\n"); } return 0; }


你可能感兴趣的:(hdu2043)