hdoj2026 首字母变大写


Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
   
   
   
   
i like acm i want to get an accepted
 

Sample Output
   
   
   
   
I Like Acm I Want To Get An Accepted
 

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int b;
    char a[101];
    while(gets(a))
    {
        b=strlen(a);
        for(int i=0;i<=b-1;i++)
        {
            if(a[i-1]==' '&&a[i]!=' '||i==0)
            {
                a[i]=a[i]-32;
            }
            printf("%c",a[i]);
        }
    printf("\n");
    }
    return 0;
}

注意:

变大写要减去32或者减去一个小写再加上对应大写字母

你可能感兴趣的:(hdoj2026 首字母变大写)