hdoj1432Lining Up

Problem Description
``How am I ever going to solve this problem?" said the pilot.


Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?

Your program has to be efficient!
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer on a line by itself indicating the number of points, followed by N pairs of integers, where 1 < N < 700. Each pair of integers is separated by one blank and ended by a new-line character. No pair will occur twice in one test case.

 

Output
For each test case, the output consists of one integer representing the largest number of points that all lie on one line, one line per case.
 

Sample Input
   
   
   
   
5 1 1 2 2 3 3 9 10 10 11
 

Sample Output
   
   
   
   
3
 代码:
#include<iostream>
#include<algorithm>
using namespace std;
struct stu{
	double x;
	double y;
}a[701];
int main()
{
	int i,j,k,t;
	while(scanf("%d",&t)!=EOF)
	{		
	for(i=1;i<=t;i++)
	{
	scanf("%lf%lf",&a[i].x,&a[i].y);
	}
	if(t==2)
	{
		printf("2\n");
	}
	else
	{
	int max=0;
	for(i=1;i<=t;i++)
	{
		for(j=i+1;j<=t;j++)
		{
			int ans=0;
			for(k=j+1;k<=t;k++)
			{				
				if((a[j].x-a[i].x)*(a[k].y-a[i].y)-(a[k].x-a[i].x)*(a[j].y-a[i].y)==0)
				{
					ans++;
				}
			}
			if(ans>max)
			{
				max=ans;
			}
		}
	}
	printf("%d\n",max+2);
}
}
	return 0;
}

思路:判断点是不是在一条线上。可以用交叉相乘相等计算,感觉也可以用斜率相等算,但写出来老是不对。

你可能感兴趣的:(hdoj1432Lining Up)