【乘法原理】【HNOI 2008】【bzoj 1008】越狱

1008: [HNOI2008]越狱

Time Limit: 1 Sec  Memory Limit: 162 MB
Submit: 5543  Solved: 2373

Description

监狱有连续编号为1…N的N个房间,每个房间关押一个犯人,有M种宗教,每个犯人可能信仰其中一种。如果相邻房间的犯人的宗教相同,就可能发生越狱,求有多少种状态可能发生越狱

Input

输入两个整数M,N.1<=M<=10^8,1<=N<=10^12

Output

可能越狱的状态数,模100003取余

Sample Input

2 3

Sample Output

6

HINT

6种状态为(000)(001)(011)(100)(110)(111)

题解:

比较水的乘法原理。
刚开始想错了,一直在想如何统计符合的,一直没想出来。
后来才想到可以统计不符合的,第一个人随便选,剩下的人都不能选和前面的人一样的,共计 m(m1)n1 种。
然后一共可能出现的方案是 mn 种,减一下就好了。

Code:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
#define p 100003LL

LL m,n,ans;

LL qp(LL x,LL y){
    LL z=1;
    while (y){
        if (y&1) z=(z*x)%p;
        x=(x*x)%p; y>>=1;
    }
    return z;
}

int main(){
    scanf("%lld%lld",&m,&n);

    ans=(qp(m,n)-(m%p)*qp(m-1,n-1))%p;
    while (ans<0) ans+=p;

    printf("%lld\n",ans);
    return 0;
}

你可能感兴趣的:(【乘法原理】【HNOI 2008】【bzoj 1008】越狱)