poj 3694 Network(tarjan+LCA求割边)

Network
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 6750   Accepted: 2397

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0

//poj 3694

#include <iostream>
#include <cstdio>
#include <cstring>
#include <utility>
#include <vector>
using namespace std;
#define N 100010
#define M 200010


vector<int>ver[N];
int head[N],dfn[N],low[N],vis[N],fa[N],dcnt,bcnt;
struct edge{
    int u,v,used,next;
}e[2*M];
bool isbridge[N];
int n,m,k;
inline void add(int u, int v )
{
    e[k].v = v; e[k].used = 0;
    e[k].next = head[u]; head[u] = k++;
}


void LCA(int u,int v)
{
    if(dfn[u] < dfn[v]) swap(u,v);
    while(dfn[u] > dfn[v])
    {
        if(isbridge[u]) bcnt--;
        isbridge[u] = false;
        u = fa[u];
    }
    while(u!=v)
    {
        if(isbridge[u]) bcnt--;
        if(isbridge[v]) bcnt--;
        isbridge[u] = isbridge[v] = false;
        u = fa[u];
        v = fa[v];
    }
}
void tarjan(int u)
{
    vis[u]=1;
    dfn[u]=low[u]=++dcnt;
    for(int k=head[u];k!=-1;k=e[k].next)
        if(!e[k].used)
        {
            e[k].used=e[k^1].used=1;
            int v=e[k].v;
            if(!vis[v])
            {
                fa[v]=u;
                tarjan(v);
                low[u]=min(low[u],low[v]);
                if(dfn[u]<low[v])
                    bcnt++,isbridge[v]=1;
            }
            else if(vis[v] == 1) low[u] = min(low[u],dfn[v]);
        }
}
int main( )
{
    //freopen("1.txt","r",stdin);
    int cas=0;
    while(scanf("%d %d",&n,&m)!=EOF&&n+m)
    {
        memset(head,-1,sizeof(head));
        k=0;
        while(m--)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            add(u,v),add(v,u);
        }
        memset(isbridge,0,sizeof(isbridge));
        memset(vis,0,sizeof(vis));
        dcnt=bcnt=0;
        fa[1]=1;
        tarjan(1);
        printf("Case %d:\n",++cas);
        int q;
        scanf("%d",&q);
        while(q--)
        {
            int u,v;
            scanf("%d %d",&u,&v);
            LCA(u,v);
            printf("%d\n",bcnt);
        }
        printf("\n");
    }
    return 0;

}

不知道为什么有一组数据答案感觉是错的

4 3

1 2

2 3

2 4

1

3 4

你可能感兴趣的:(poj 3694 Network(tarjan+LCA求割边))