[poj 1850] Code 组合数学

Code
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9102 Accepted: 4346

Description
Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, …, z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2

z - 26
ab - 27

az - 51
bc - 52

vwxyz - 83681

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input
The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.

Output
The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source
Romania OI 2002

题目链接:http://poj.org/problem?id=1850;

题意:输出某个str字符串在字典中的位置,由于字典是从a=1开始的,因此str的位置值就是 在str前面所有字符串的个数 +1
规定输入的字符串必须是升序排列;

思路
1.判断输入的str是否是升序序列;
2.计算小于其长度的数 c[26][i];
3.同长度tt位置后面(不包括tt)剩下的位数,就是从’z’-tt选择len-1-i个字符(i位缩小,保证升序,的组合数累加);

代码

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
int c[27][27];
char s[15];
void com()
{
    for(int i=0;i<=26;i++)
    for(int j=0;j<=i;j++)
    {
        if(!j||i==j) 
        {
            c[i][j]=1;
        } else c[i][j]=c[i-1][j]+c[i-1][j-1];
    }
}



int main()
{

        com();
        scanf("%s",s);

        int ans=0;
        int len=strlen(s);
        for(int i=0;i<len;i++)
        if(s[i]<=s[i-1])
        {
             printf("0\n");
             return 0;
        }   
        for(int i=1;i<len;i++)
        ans+=c[26][i];
        //cout<<ans<<endl;
        for(int i=0;i<len;i++)
        {
            char tt;
            if(i) tt=s[i-1]+1;
            else tt='a';    
            while(tt<s[i])
            {
                ans+=c['z'-tt][len-1-i];    
                tt++;
            }   

        }
        printf("%d\n",++ans);

}        

你可能感兴趣的:(数学,poj)