第六届福建省大学生程序设计竞赛 Problem B Common Tangents【几何】

Problem B Common Tangents

Accept: 183    Submit: 587
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.


Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

3
10 10 5 20 20 5
10 10 10 20 20 10
10 10 5 20 10 5

Sample Output

4
2
3
解题思路:
有多少条切线,分情况讨论,根据圆心间距离和半径的关系。
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
double f1(int x1,int y1,int x2,int y2)
{
	double L;
	L=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
	return L;
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int x1,y1,r1,x2,y2,r2;
		scanf("%d%d%d%d%d%d",&x1,&y1,&r1,&x2,&y2,&r2);
		double LL;
		LL=f1(x1,y1,x2,y2);
		if(x1==x2&&y1==y2&&r1==r2)
		{
			printf("-1\n");
			continue;
		}
		if(LL+r1==r2||LL+r2==r1)
		{
			printf("1\n");
			continue;
		}
		if(LL>r1+r2)
		{
			printf("4\n");
		}
		else if(LL==r1+r2)
		{
			printf("3\n");
		}
		else if(LL<r1+r2)
		{
			if(LL>r1&&LL>r2)
			{
				printf("2\n");
			}
			else
			{
				printf("0\n");
			}
		}
	}
	return 0;
}


你可能感兴趣的:(第六届福建省大学生程序设计竞赛)