hdu2844 Coins --多重背包

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=2844


一:原题内容

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 
Output
For each test case output the answer on a single line.
 
Sample Input
   
   
   
   
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 
Sample Output
   
   
   
   
8 4

二:分析理解

一个模板题!!


三:AC代码

#include<iostream>  
#include<algorithm>  

using namespace std;

int dp[100005];
int value[105];
int number[105];
int n, m;

void ZeroOnePack(int value, int weight)
{
	for (int i = m; i >= value; i--)
		dp[i] = max(dp[i], dp[i - value] + weight);
}

void CompletePack(int value, int weight)
{
	for (int i = value; i <= m; i++)
		dp[i] = max(dp[i], dp[i - value] + weight);
}

void MultiplePack(int value, int weight, int number)
{
	if (number*value >= m)
	{
		CompletePack(value, weight);
		return;
	}

	int k = 1;
	while (k <= number)
	{
		ZeroOnePack(k*value, k*weight);
		number -= k;
		k *= 2;
	}
	ZeroOnePack(number*value, number*weight);
}
int main()
{
	while (~scanf("%d%d", &n, &m), n + m)
	{
		memset(dp, 0, sizeof(dp));

		for (int i = 0; i < n; i++)
			scanf("%d", &value[i]);

		for (int i = 0; i < n; i++)
			scanf("%d", &number[i]);

		for (int i = 0; i < n; i++)
			MultiplePack(value[i], value[i], number[i]);

		int num = 0;
		for (int i = 1; i <= m; i++)
			if (dp[i] == i)
				num++;

		printf("%d\n", num);
	}
	return 0;
}


你可能感兴趣的:(C++,算法,dp,HDU)