poj 2421 Constructing Roads

Constructing Roads
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 21632   Accepted: 9175

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

PKU Monthly,kicc

题意:有n个村庄,有n行数据,每行是每个村庄到其他村庄的距离,又输入已经修好路的村庄的编号,求使各村庄连通,需要修路的最短距离
不是很难,注意只有一组数据
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[110];
struct node
{
	int from;
	int to;
	int vis;
}t[11000];
bool cmp(node a,node b)
{
	return a.vis<b.vis;
}
int find(int x)
{
	if(x==pre[x])
	return x;
	return pre[x]=find(pre[x]);
}
int  merge(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{
		pre[fx]=fy;
		return 1;
	}
	return 0;
}
int main()
{
	int i,j,k,l,m,n,a,b,p;
	int sum=0;
	scanf("%d",&n);
	k=0;
	for(i=1;i<=n;i++)
	pre[i]=i;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			scanf("%d",&m);
			if(i==j)
			continue;
			else
			{
				t[k].from=i;
			    t[k].to=j;
			    t[k].vis=m;
			    k++;
			 } 	
		}
	}
		scanf("%d",&p);
		while(p--)
		{
			scanf("%d%d",&a,&b);
		    merge(a,b);//已经连通的村庄 
		}
		sort(t,t+k,cmp);
		for(i=0;i<k;i++)
		{
			if(merge(t[i].from,t[i].to))
				sum=sum+t[i].vis;
		}
		printf("%d\n",sum);	
}



你可能感兴趣的:(poj 2421 Constructing Roads)