Bad Cowtractors
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 12756 |
|
Accepted: 5294 |
Description
Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie.
Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.
Output
* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.
Sample Input
5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17
Sample Output
42
Hint
OUTPUT DETAILS:
The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.
Source
USACO 2004 December Silver
题解:
给出n个顶点,以及连接这些顶点的m 条边以及边的长度,求使得所有顶点连通,并且不存在环,问边长最大和为多少
题解:
最大生成树,kruscal 算法即可.....
没注意看题目要求,错了两次......无语,太粗心了...
/*
http://blog.csdn.net/liuke19950717
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1005;
int pre[maxn];
struct node
{
int a,b,c;
}edge[maxn*20];
int cmp(node a,node b)
{
return a.c>b.c;
}
void init(int n)
{
for(int i=1;i<=n;++i)
{
pre[i]=i;
}
}
int find(int x)
{
int r=x;
while(r!=pre[r])
{
r=pre[r];
}
int i=x,j;
while(i!=r)
{
j=pre[i];pre[i]=r;
i=j;
}
return r;
}
int join(int x,int y)
{
int fx=find(x),fy=find(y);
if(fx!=fy)
{
pre[fx]=fy;
return 1;
}
return 0;
}
int slove(int n,int m)
{
sort(edge,edge+m,cmp);
int cnt=0,ans=0;
for(int i=0;i<m&&cnt<n-1;++i)
{
if(join(edge[i].a,edge[i].b))
{
ans+=edge[i].c;
++cnt;
}
}
if(cnt<n-1)
{
return -1;
}
return ans;
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
init(n);
for(int i=0;i<m;++i)
{
scanf("%d%d%d",&edge[i].a,&edge[i].b,&edge[i].c);
}
printf("%d\n",slove(n,m));
}
}