HDU 1068 Girls and Boys (二分匹配)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9773    Accepted Submission(s): 4474


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
   
   
   
   
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
   
   
   
   
5 2
 

Source
Southeastern Europe 2000
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1150  1151  1281  1507  1528 
最大独立集指的是两两之间没有边的顶点的集合,顶点最多的独立集成
为最大独立集。二分图的最大独立集=节点数-(减号)最大匹配数
本题是要找出最大的没有关系的集合,即最大独立集。而求最大独立集重点在于求最大匹配数,
本题中给出的是同学之间的亲密关系,并没有指出哪些是男哪些是女,所以求出的最大匹配数
要除以2才是真正的匹配数。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int pre[2100];
bool map[2010][2010];
int flag[2010];
int n;
int find(int cur)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(map[cur][i]&&!flag[i])//有关系,并且没有标记过 
		{
			flag[i]=true;//标记 
			if(pre[i]==-1||find(pre[i]))//没有被占用,或者能腾出位子来 
			{
				pre[i]=cur;
				return 1;
			}
		}
	}
	return 0;
 } 
 int main()
 {
 	while(scanf("%d",&n)!=EOF)
 	{
 		int sum=0;
 		memset(map,false,sizeof(map));
 		memset(pre,-1,sizeof(pre));
 		int p,q,k,i,j;
 		for(i=0;i<n;i++)
 		{
 			scanf("%d: (%d) ",&p,&q);
 			for(j=0;j<q;j++)
 			{
 				scanf("%d",&k);
 				map[p][k]=true;
			 }
		 }
		 for(i=0;i<n;i++)
		 {
		 	memset(flag,0,sizeof(flag));
		 	sum+=find(i); 
		 }
		 printf("%d\n",n-sum/2);
	 }
	 return 0;
 }



你可能感兴趣的:(HDU 1068 Girls and Boys (二分匹配))