HDU 5630 Rikka with Chess

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 499    Accepted Submission(s): 416


Problem Description
Yuta gives Rikka a chess board of size n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 

Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109) .
 

Output
For each testcase, print a single number which represents the answer.
 

Sample Input
   
   
   
   
3 1 2 2 2 3 3
 

Sample Output
   
   
   
   
1 2 2
 

Source
BestCoder Round #73 (div.2)
 

Recommend

hujie



#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
__int64 n,m,sum,t;
scanf("%I64d",&t);
while(t--)
{
scanf("%I64d%I64d",&n,&m);
sum=n/2+m/2;
printf("%I64d\n",sum);
}
return 0; 
}




你可能感兴趣的:(HDU 5630 Rikka with Chess)