HDOJ 3625 Examining the Rooms(斯特林数—求n个点形成k个环的方案数)

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1324    Accepted Submission(s): 809


Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
 

Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
 

Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
 

Sample Input
   
   
   
   
3 3 1 3 2 4 2
 

Sample Output
   
   
   
   
0.3333 0.6667 0.6250
Hint
Sample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
 

题意:有n个房间的门全部关闭,所有房间的钥匙都在房间内(i号房间的钥匙不一定在i号房间内部)。有k次机会可以用暴力手段打开某个房间门。 但是第一个房间门不可以使用暴力手段打开,必须在其他房间拿到钥匙再打开。 给出n和k,问打开所有房间的概率是多大?


题解:我们知道如果1号房间的钥匙在1号房间内是不可能完成任务的。  通过打开一个房间门去获得打开下一个房间门的钥匙,这里构成了成环条件。 问题就变成了在给出n个点判断在形成1~k个环的总方案数。然后除以所有的钥匙分配可能n!。  注意1号房间不能独立成环。

那么如何求n个点形成m个环的方案数呢? 这里我们用到了组合数学中的斯特林数  百度百科 

根据定义我们使用第一类斯特林数: S(n,k) = S(n-1,k-1) + (n-1) * S(n-1,k), 表示的就是n个元素形成k个非空循环数列的方案数。 对于这个递推式为什么成立,给出简单证明:

考虑其定义如果要将n元素构成k个圆排列,考虑第n个元素:

(1)如果n-1个元素构成了k-1个圆排列,那么第n个元素独自构成一个圆排列。方案数S(n-1,k-1)  。

(2)如果n-1个元素构成了k个圆排列,将第n个元素插入到任意元素的左边。方案数(n-1)* S(n-1,k)。

枚举所有1~k的所有方案数,但要排除掉1号房间独立成环的情况。

有:  ans+=( S(n,i)  -  S(n-1,i-1) )。

代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
#define LL long long
LL stir[25][25];
LL sum[25]; 
int main()
{
	int i,j;
	sum[0]=1;
	for(i=1;i<=20;++i)
		sum[i]=i*sum[i-1];
	for(i=1;i<=20;++i)
	{
		stir[i][0]=0;
		stir[i][i]=1;
		for(j=1;j<i;++j)
			stir[i][j]=stir[i-1][j-1]+(i-1)*stir[i-1][j];
	}
	int t,n,k;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&k);
		if(n==1||k==0)
		{
			printf("0.0000\n");
			continue;
		}
		LL ans=0;
		for(i=1;i<=k;++i)
			ans+=(stir[n][i]-stir[n-1][i-1]);
		printf("%0.4lf\n",(ans*1.0)/sum[n]);
	}
	return 0;
} 



你可能感兴趣的:(HDOJ 3625 Examining the Rooms(斯特林数—求n个点形成k个环的方案数))