DP:Divide Chocolate

Divide Chocolate

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 706    Accepted Submission(s): 325


Problem Description
It is well known that claire likes dessert very much, especially chocolate. But as a girl she also focuses on the intake of calories each day. To satisfy both of the two desires, claire makes a decision that each chocolate should be divided into several parts, and each time she will enjoy only one part of the chocolate. Obviously clever claire can easily accomplish the division, but she is curious about how many ways there are to divide the chocolate.
DP:Divide Chocolate_第1张图片
To simplify this problem, the chocolate can be seen as a rectangular contains n*2 grids (see above). And for a legal division plan, each part contains one or more grids that are connected. We say two grids are connected only if they share an edge with each other or they are both connected with a third grid that belongs to the same part. And please note, because of the amazing craft, each grid is different with others, so symmetrical division methods should be seen as different.
 

Input
First line of the input contains one integer indicates the number of test cases. For each case, there is a single line containing two integers n (1<=n<=1000) and k (1<=k<=2*n).n denotes the size of the chocolate and k denotes the number of parts claire wants to divide it into.
 

Output
For each case please print the answer (the number of different ways to divide the chocolate) module 100000007 in a single line.&#160;
 

Sample Input
   
   
   
   
2 2 1 5 2
 

Sample Output
   
   
   
   
1 45

直接DP,状态表示 f[i][0][j]:前i行已经出现了j部分且第i行的两个格子属于同一部分的方法数,

f[i][1][j]:前i行已经出现了j部分且第i行的两个格子属于不同部分的方法数

初始条件 f[1][0][1]=f[1][1][2]=1

状态转移方程如下:

DP:Divide Chocolate_第2张图片                   

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

#define mod 100000007
int f[1005][2][2010]; //i代表列数;
                      // 0代表第i行两个子在一起,1代表不在一起
                      //j代表到第i行有j块
int ini(){
    int i, j, k;
    memset(f,0,sizeof(f));
    f[1][0][1]=1;
    f[1][1][2]=1;
    for(i=2;i<=1001;i++){//代表每列的意思
        for(j=1;j<=2*i;j++){ //循环到2*i的原因是最多2*i块
            f[i][0][j]=(f[i-1][0][j]+f[i-1][1][j]*2+f[i-1][0][j-1]+f[i-1][1][j-1]) % 100000007;
            f[i][1][j]=(f[i-1][0][j-1]*2+f[i-1][1][j]+f[i-1][1][j-1]*2)% 100000007;
            if(j>=2)f[i][1][j]+=(f[i-1][0][j-2]+f[i-1][1][j-2]) % 100000007;
        }
    }
}

int main(){
    int c, n, k;
    cin >> c;
    ini();
    while( c --)
    {
        cin >> n >> k;
        cout<<( f[n][0][k] + f[n][1][k] ) % 100000007 << endl;
    }
    return 0;
}




你可能感兴趣的:(DP:Divide Chocolate)