hdu 1045 fire net


《ACM程序设计》期末上机考试安排

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8671    Accepted Submission(s): 5007


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

hdu 1045 fire net_第1张图片

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
       
       
       
       
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
       
       
       
       
5 1 5 2 4

题目意思不难,就是求放置castle个数最多个数,直接用递归。数据量不大,很容易解决。

#include<iostream>
#include<cstring>
#include<algorithm>
#include<string>
using namespace std;
char mapx[5][5],mark[5][5];
int t,maxi;

int fun(int ii,int jj)
{
 
 for(int x=jj+1;x<=t;x++)
 {
  if(mark[ii][x])//如果ii ,jj 的领接位置被放过了,该位置不(ii,jj) 不能再放了。
      return 0;
      if(mapx[ii][x]=='X')//领接所有位置是先遇到X, 最后返回1;
      break;
 }
 
 for(int x=jj-1;x>=1;x--)
 {
   if(mark[ii][x])
      return 0;
      if(mapx[ii][x]=='X')
      break;
 }
 
 
 for(int y=ii+1;y<=t;y++)
 {
  if(mark[y][jj])
      return 0;
      if(mapx[y][jj]=='X')
      break;
 }
 
 
 for(int y=ii-1;y>=1;y--)
 {
  if(mark[y][jj])
     return 0;
     if(mapx[y][jj]=='X')
     break;
 }
 
 return 1;
}

void dfs(int cnt)//cnt 表示在空位置已置放的个数
{
      if(cnt>maxi)
      {
        maxi=cnt;
      }
 for(int i=1;i<=t;i++)//用两个for()语句对所有位置放置;
 {
  for(int j=1;j<=t;j++)
  {
  if(mapx[i][j]=='.'&&mark[i][j]==0)//初始判断
  {
   if(fun(i,j))//进一步判断该位置的前后左右的合法性
   {
       //cout<<i<<" "<<j<<endl;
    mark[i][j]=1;
    dfs(cnt+1);
    mark[i][j]=0;
   }
  }
  }
 }
}

int main()
{
 while(cin>>t,t)
 {
  maxi=0;
  memset(mark,0,sizeof(mark));
  for(int i=1;i<=t;i++)
  for(int j=1;j<=t;j++)
  cin>>mapx[i][j];
  dfs(0);
  cout<<maxi<<endl;
 }
 return 0;
}


你可能感兴趣的:(ACM)