POJ 2560 Freckles

Freckles

Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

In an episode of the Dick Van Dyke show, little Richie connects the freckles on his Dad’s back to form a picture of the Liberty Bell. Alas, one of the freckles turns out to be a scar, so his Ripley’s engagement falls through.
Consider Dick’s back to be a plane with freckles at various (x, y) locations. Your job is to tell Richie how to connect the dots so as to minimize the amount of ink used. Richie connects the dots by drawing straight lines between pairs, possibly lifting the pen between lines. When Richie is done there must be a sequence of connected lines from any freckle to any other freckle.
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The first line contains 0 < n ≤ 100, the number of freckles on Dick’s back. For each freckle, a line follows; each following line contains two real numbers indicating the (x, y) coordinates of the freckle.
Output
For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the freckles.
Sample Input
1
3
1.0 1.0
2.0 2.0
2.0 4.0
Sample Output
3.41

大致题意:给你n个点的坐标,求把所有的点连起来,所用的墨水最少
分析:最小生成树模板题
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<algorithm>

using namespace std;

int n;//顶点数
struct pp
{
    double x,y;
}a[110];//存储n个节点的坐标
double cost[110][110];//cost[i][j]表示e = (i,j)的权值
int used[110];//顶点i是否包含在集合X中
double mincost[110];//从集合X出发的边到每个顶点的最小权值
const int INF = 0x3f3f3f3f;

double prime()
{
    for(int i = 0;i < n;i++)//初始化
    {
        used[i] = 0;
        mincost[i] = INF;
    }
    mincost[0] = 0.0;
    double res = 0.0;
    while(1)
    {
        int v = -1;
        //从不属于X的顶点中选取从X到其权值最小的顶点
        for(int i = 0;i < n;i++)
        {
            if(!used[i] && (v == -1 || mincost[i] < mincost[v]))
                v = i;
        }
        if(v == -1)
            break;
        used[v] = 1;//把顶点v加入X
        res += mincost[v];//把边的长度加到结果里
        for(int i = 0;i < n;i++)
        {
            mincost[i] = min(mincost[i],cost[v][i]);
        }
    }
    return res;
}

int main()
{
    int t,cont = 0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i = 0;i < n;i++)
        {
            scanf("%lf %lf",&a[i].x,&a[i].y);
        }
        memset(cost,INF,sizeof(cost));
        for(int i = 0;i < n;i++)
        {
            for(int j = 0;j < n;j++)
            {
                if(i != j)
                {
                    //保存各个顶点之间距离,即e = (i,j)的权值 
                    double q =  sqrt((a[i].x - a[j].x) * (a[i].x - a[j].x) + (a[i].y - a[j].y) * (a[i].y - a[j].y));
                    cost[i][j] = q;
                }
            }
        }
        double res = prime();
        if(cont > 0)
            printf("\n");
        cont ++;
        printf("%.2lf\n",res);
    }
    return 0;
}



你可能感兴趣的:(Prime)