HDU 4287 Intelligent IME

G - Intelligent IME
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

HDU 4287
Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below: 
  2 : a, b, c 3 : d, e, f 4 : g, h, i 5 : j, k, l 6 : m, n, o 
  7 : p, q, r, s 8 : t, u, v 9 : w, x, y, z 
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences? 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this: 
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words. 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line. 

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn 

Sample Output
3
2


#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <queue>
#include <list>
#include <map> 

using namespace std;
const int  MAXN =5050;
map<int ,int>tt;
int main()
{int n;
cin>>n;
int vis[MAXN]={2,2,2,3,3,3,4,4,4,5,5,5,6,6,6,7,7,7,7,8,8,8,9,9,9,9};
int s[MAXN];
while(n--)
{  tt.clear();
int i,j,k;
int a,b;
cin>>a>>b;
for(i=0;i<a;i++)
    cin>>s[i];
string tep;
int num;
for(i=0;i<b;i++)
{  num=0;
    cin>>tep;
    int d=tep.length();
     for(k=0;k<d;k++)
    {
        num=num*10+vis[tep[k]-'a'];//将字符串转化为对应的数字。
    }
    tt[num]++; //相同数字的个数相加
}
   for(i=0;i<a;i++)
   {
       cout<<tt[s[i]]<<endl;       //输出对应的个数。

   }
}
    return 0;
}




 
        

你可能感兴趣的:(HDU 4287 Intelligent IME)