FZU 2039 Pets【二分匹配】

 Problem 2039 Pets

Accept: 395    Submit: 1061
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Are you interested in pets? There is a very famous pets shop in the center of the ACM city. There are totally m pets in the shop, numbered from 1 to m. One day, there are n customers in the shop, which are numbered from 1 to n. In order to sell pets to as more customers as possible, each customer is just allowed to buy at most one pet. Now, your task is to help the manager to sell as more pets as possible. Every customer would not buy the pets he/she is not interested in it, and every customer would like to buy one pet that he/she is interested in if possible.

FZU 2039 Pets【二分匹配】_第1张图片

 Input

There is a single integer T in the first line of the test data indicating that there are T(T≤100) test cases. In the first line of each test case, there are three numbers n, m(0≤n,m≤100) and e(0≤e≤n*m). Here, n and m represent the number of customers and the number of pets respectively.

In the following e lines of each test case, there are two integers x(1≤x≤n), y(1≤y≤m) indicating that customer x is not interested in pet y, such that x would not buy y.

 Output

For each test case, print a line containing the test case number (beginning with 1) and the maximum number of pets that can be sold out.

 Sample Input

1
2 2 2
1 2
2 1

 Sample Output

Case 1: 2

 Source

2011年全国大学生程序设计邀请赛(福州)

题目大意:有n个顾客,商店里边有m只pet。给出一些关系,表示顾客x不想要y号宠物。

思路:二分图匹配。如果顾客x不想要y号宠物,辣么就表示呢,y号宠物不能去匹配x号人。然后上模板,AC。。。。。。。。。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn = 505;
int map[maxn][maxn];              //图的数组.
int vis[maxn];                  //标记数组.
int pri[maxn];
int k,m,n;
int  find(int x)
{
    for(int i=1;i<=m;i++)
    {
        if(vis[i]==0&&map[i][x])
        {
            vis[i]=1;
            if(pri[i]==-1||find(pri[i]))
            {
                pri[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&k);
        memset(pri,-1,sizeof(pri));
        memset(map,1,sizeof(map));
        for(int i=0;i<k;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            map[v][u]=0;
        }
        int output=0;
        for(int i=1;i<=n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
            {
                output++;
            }
        }
        printf("Case %d: %d\n",++kase,output);
    }
}








你可能感兴趣的:(2039,FZU)