HDU 1194 Beat the Spread!(数学问题呀..)

Beat the Spread!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5837    Accepted Submission(s): 3076


Problem Description

Superbowl Sunday is nearly here. In order to pass the time waiting for the half-time commercials and wardrobe malfunctions, the local hackers have organized a betting pool on the game. Members place their bets on the sum of the two final scores, or on the absolute difference between the two scores.

Given the winning numbers for each type of bet, can you deduce the final scores?
 


Input

The first line of input contains n, the number of test cases. n lines follow, each representing a test case. Each test case gives s and d, non-negative integers representing the sum and (absolute) difference between the two final scores.
 


Output

For each test case, output a line giving the two final scores, largest first. If there are no such scores, output a line containing "impossible". Recall that football scores are always non-negative integers.
 


Sample Input

   
   
   
   
2 40 20 20 40
 


Sample Output

   
   
   
   
30 10 impossible
 


Source

University of Waterloo Local Contest 2005.02.05

原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1194

题意:输入两个数的和与差,求这两个数,按从大到小的输出.
假设两个数的和与差分别为a,b,如果这两个数存在的话,这两个数分别为x=(a+b)/2; y=(a-b)/2;

AC代码:

#include <stdio.h>
int main()
{
    int n,a,b,x,y;
    scanf("%d",&n);
    while (n--)
    {
        scanf("%d %d",&a,&b);
        if(a<b)
            printf("impossible\n");
        else if((a+b)%2!=0)//这两个数的和与差同奇偶
            printf("impossible\n");
        else
        {
            x=(a+b)/2;
            y=(a-b)/2;
            if(x<y)
            {
                int t=x;
                x=y;
                y=t;
            }
            printf("%d %d\n",x,y);
        }
    }
    return 0;
}


你可能感兴趣的:(Spread,the,Beat,HDU1194)