poj 1007 DNA Sorting

Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequenceZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to “least sorted”. All the strings are of the same length.
Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output

Output the list of input strings, arranged from most sorted'' toleast sorted”. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

这题主要就是一个排序;
但是注意需要一个稳定的排序;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<set>
#include<map>
#include<utility>
using namespace std;
struct DNA
{
    int id;
    int sum;
};
bool cmp(const DNA &a,const DNA &b)
{
    return a.sum<b.sum;
}
int main()
{
    int n,m;
    DNA p[101];
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;++i)
    {
        p[i].id=0;
        p[i].sum=0;
    }
    char s[101][51];
    for(int i=0;i<m;++i)
        for(int j=0;j<n;++j)
    {
        scanf(" %c",&s[i][j]);
    }
    for(int i=0;i<m;++i)
    {
        p[i].id=i;
        for(int j=0;j<n;++j)
        {
            for(int k=j+1;k<n;++k)
            {
                if(s[i][j]>s[i][k])
                {
                    ++p[i].sum;
                }
            }
        }
    }
    sort(p,p+m,cmp);
    for(int i=0;i<m;++i)
    {
        for(int j=0;j<n;++j)
        {
            printf("%c",s[p[i].id][j]);
            if(j==n-1) printf("\n");
        }
    }
    return 0;
}

你可能感兴趣的:(poj)