Pat(Advanced Level)Practice--1054(The Dominant Color)

Pat1054代码

题目描述:

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 224). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:
5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24
Sample Output:
24

AC代码:(一)
#include<cstdio>
#include<map>

using namespace std;

int main(int argc,char *argv[])
{
	int i,j;
	int m,n;
	map<int,int> v;
	scanf("%d%d",&m,&n);
	for(i=0;i<n;i++)
		for(j=0;j<m;j++)
		{
			int temp;
			scanf("%d",&temp);
			v[temp]++;
		}

	map<int,int>::iterator it;
	for(it=v.begin();it!=v.end();it++)
		if(it->second>m*n/2)
			break;
	printf("%d\n",it->first);

	return 0;
}

其实我觉得可以把本题转换成求众数的问题,不知道为什么最后一个case错误。还是贴出来以后再看吧!为什么???
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;

int main(int argc,char *argv[])
{
	int i,j,len;
	int ans,temp;
	vector<int> v;
	int n,m;
	scanf("%d%d",&m,&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		{
			scanf("%d",&temp);
		    v.push_back(temp);
		}
	}
	sort(v.begin(),v.end());
	len=1;
	for(i=1;i<m*n;i++)
		if(v[i]==v[i-len])
		{
			len++;
			ans=v[i];
			if(len>n*m/2)
				break;
		}
	printf("%d\n",ans);

	return 0;
}

AC代码:(二)
#include<cstdio>

using namespace std;

int main(int argc,char *argv[])
{
	int m,n;
	int i,j;
	int ans,count=0;
	scanf("%d%d",&m,&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		{
			int temp;
			scanf("%d",&temp);
			if(count==0)
			{
				ans=temp;
				count=1;
			}
			else
			{
				if(ans==temp)
					count++;
				else
					count--;
			}
		}
	}
	printf("%d\n",ans);

	return 0;
}

因为该数出现的次数超过一半,所以遇到不相同的数则计数减一,最后剩下的数肯定是出现次数最多的数。。。

AC代码:(三)因为该数出现的次数超过一半,所以排序后中位数一定是它。。。
#include<cstdio>
#include<vector>
#include<algorithm>

using namespace std;

int main(int argc,char *argv[])
{
	int i,j,len;
	int temp;
	vector<int> v;
	int n,m;
	scanf("%d%d",&m,&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		{
			scanf("%d",&temp);
		    v.push_back(temp);
		}
	}
	sort(v.begin(),v.end());
	printf("%d\n",v[(m*n)/2]);

	return 0;
}


你可能感兴趣的:(C++,pat,基础题,advance)