POJ1068 Parencodings(括号匹配)


Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 23787   Accepted: 13965

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9
题目大意:规定两种括号的编码方式:1:每个数字表示该右括号左边有几个左括号 2::每个数组表示该右括号左边的第几个左括号与之匹配。给定编码1求编码2。

思路:开一个数组,0表示左括号,1表示右括号,先读入数据表示出括号的位置,然后对有个右括号寻找与之匹配的左括号,寻找时对匹配的左括号标记为-1.

技巧:读入一个数字时即可知道该括号所在的位置。

如4 5 6 6 6 6 中4可知第figure[4+0]为右括号1, 5可知figure[5+1]为右括号1。因为读入的数字表示左边有几个左括号,在加上前面的右括号数即可。

实现代码:

//************************************************************************//
//*Author : Handsome How                                                 *//
//************************************************************************//
//#pragma comment(linker, "/STA	CK:1024000000,1024000000")
#include<cstdio>
#include<cstring>
#define fur(i,a,b) for(int i=(a);i<=(b);i++)
#define furr(i,a,b) for(int i=(a);i>=(b);i--)
using namespace std;
typedef long long LL;
int figure[50];
int find(int a)
{
	int dis = 1;
	for (a--; a >= 0; a--)
	{
		if (figure[a] == 0) { figure[a] = -1; break; }	  //标记退出
		if (figure[a] == -1) { dis++; continue; }
	}
	return dis;
}
int main()
{
	//freopen("E:\\data.in", "r", stdin);
	//freopen("E:\\data.out", "w", stdout);
	int T;
	int right[25];							   //记录右括号的位置
	scanf("%d", &T);
	while (T--)
	{
		int len;
		memset(figure, 0, sizeof(figure));	   //先全部设置为左括号
		scanf("%d", &len);
		fur(i, 0, len - 1)
		{
			scanf("%d", &right[i]);
			right[i] += i;
			figure[right[i]] = 1;
		}
		fur(i,0,len-1)
			printf("%d ",find(right[i]));
		printf("\n");
	}
	return 0;
}



你可能感兴趣的:(POJ1068 Parencodings(括号匹配))