HDOJ 2647 Reward(拓扑排序(节点含值)+邻接表)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5678    Accepted Submission(s): 1720


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
   
   
   
   
2 1 1 2 2 2 1 2 2 1
 

Sample Output
   
   
   
   
1777 -1 刚开始用邻接矩阵写的,MTL,看了下数据范围,1w.....然后换一直没用过的邻接表,用普通拓扑排序写了一发, 数据都对,但是还是wrong,然后回去看了看PPT,看到能用队列来写,就换姿势写一发,过了..... ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
#include<iostream>
#include<algorithm>
#define INF 0x7fffffff
#define MAXN 10100
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int v[51000];
struct s
{
	int next;
	int d;
}a[51000];
int head[51000];
int num[51000];
void topo(int n)
{
    int k,i,j;
    int ans=0;
    int sum=0;
    queue<int>qq;
    for(i=1;i<=n;i++)
    {
    	if(v[i]==0)
    	qq.push(i);
	}
	while(!qq.empty())
	{
		k=qq.front();
		qq.pop();
		ans++;
		for(j=head[k];j!=-1;j=a[j].next)
		{
			v[a[j].d]--;
			if(v[a[j].d]==0)
			{
				qq.push(a[j].d);
				num[a[j].d]=num[k]+1;//不知道怎么说,改变值的大小
			}
		}
	}
	for(i=1;i<=n;i++)
	sum+=num[i];
    if(ans!=n)
    printf("-1\n");
    else
    printf("%d\n",sum);
}
int main()
{
    int n,m,i,j,q,w;
    while(scanf("%d%d",&n,&m)!=EOF)
	{
    	memset(v,0,sizeof(v)); 
    	memset(head,-1,sizeof(head));
    	for(i=1;i<=n;i++)
		num[i]=888;//赋初值
        for(i=0;i<m;i++)
		{
            scanf("%d%d",&q,&w);//创建邻接表
			a[i].d=q;
			a[i].next=head[w];
			head[w]=i;
			v[q]++;
        }
        topo(n);
    }
    return 0;
}


你可能感兴趣的:(HDOJ 2647 Reward(拓扑排序(节点含值)+邻接表))