Cash Machine
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 31500 |
|
Accepted: 11318 |
Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output
735
630
0
0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
题意:输出m,n,m代表目标金额,n代表有的硬币种类数, 后面有2n个整数,表示硬币数目及对应的价值。问你在1~m之间用这些硬币最多能组成多少钱。
思路:一看就知道是多重背包,我试了下多重背包三种解法里的两种优化的比较好的,都过了。不知道直接拆解成j个物品能不能过。
代码1 (二进制优化):
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 100010
#define M 1500
int dp[N];
int v[N];
int main()
{
int cash,n;
int num,val;
while(~scanf("%d",&cash))
{
int cnt=0;
scanf("%d",&n);
memset(dp,0,sizeof(dp));
for(int i=0; i<n; i++)
{
int t=1;
scanf("%d %d",&num,&val);
while(t<=num)
{
v[cnt++]=val*t;
num-=t;
t*=2;
}
v[cnt++]=num*val;
}
for(int i=0; i<cnt; i++)
{
for(int k=cash; k>=v[i]; k--)
{
dp[k]=max(dp[k],dp[k-v[i]]+v[i]);
}
}
printf("%d\n",dp[cash]);
}
return 0;
}
代码2(单调队列优化):
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 100010
#define M 15
int dp[N];
int a[N],b[N];
int cash,n;
int s,e;
void update(int x,int y)
{
while(s<=e&&b[e]<=y) {e--;}
a[++e]=x;b[e]=y;
}
int main()
{
int num,val;
while(~scanf("%d %d",&cash,&n))
{
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
{
scanf("%d %d",&num,&val);
if(!num)
continue;
if(cash/val<num)
num=cash/val;
for(int d=0; d<val; d++)
{
s=1;e=0;
for(int j=0; j<=(cash-d)/val; j++)
{
update(j,dp[j*val+d]-j*val);
if(a[s]<j-num) s++;
dp[j*val+d]=b[s]+j*val;
}
}
}
printf("%d\n",dp[cash]);
}
return 0;
}