HDOJ 1305 Immediate Decodability (字典树判断是否存在子串)

Immediate Decodability

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2361    Accepted Submission(s): 1220


Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
 

Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
 

Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
 

Sample Input
   
   
   
   
01 10 0010 0000 9 01 10 010 0000 9
 

Sample Output
   
   
   
   
Set 1 is immediately decodable Set 2 is not immediately decodable
 


ac代码:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stack>
#include<iostream>
#include<algorithm>
#define fab(a) (a)>0?(a):(-a)
#define LL long long
#define MAXN 10010
#define mem(x) memset(x,0,sizeof(x))
#define INF 0xfffffff 
using namespace std;
struct s
{
	int num;
	s *next[10];
};
struct word
{
	char phone[12];
	int len;
}a[MAXN];
s *root;
bool cmp(word q,word w)
{
	return q.len<w.len;
}
void create(char *str)
{
	int len=strlen(str);
	s *p=root,*q;
	for(int i=0;i<len;i++)
	{
		int id=str[i]-'0';
		if(p->next[id]==NULL)
		{
			q=(s *)malloc(sizeof(s));
			q->num=1;
			for(int j=0;j<10;j++)
			q->next[j]=NULL;
			p->next[id]=q;
			p=p->next[id];
		}
		else
		{
			p->next[id]->num++;
			p=p->next[id];
		}
	}
	//p->num=-1;
}
int find(char *ss)
{
	int len=strlen(ss);
	s *p=root;
	for(int i=0;i<len;i++)
	{
		int id=ss[i]-'0';
		p=p->next[id];
		if(p==NULL)
		return 0;
//		if(p->num==-1)
//		return -1;
	}
	return p->num;
}
void begin()
{
	for(int i=0;i<10;i++)
	root->next[i]=NULL;
}
void freetree(s *t)
{
	if(t==NULL)
	return;
	for(int i=0;i<10;i++)
	{
		if(t->next[i]!=NULL)
		freetree(t->next[i]);
	}
	free(t);
	return;
}
int main()
{
	
	int i,n;
	int cnt=0;
	while(scanf("%s",a[0].phone)!=EOF)
	{
		int k=1;
	    while(scanf("%s",a[k].phone)!=EOF,a[k].phone[0]!='9')
	    {
		    int l=strlen(a[k].phone);
			a[k].len=l;
			k++;
		}
	//	printf("%s\n",a[k-1].phone);
		int bz=0;
		root=(s *)malloc(sizeof(s));
		begin();
		sort(a,a+k,cmp);
		create(a[k-1].phone);
		for(i=k-2;i>=0;i--)
		{
			if(find(a[i].phone)==0)
			create(a[i].phone);
			else
			{
				bz=1;;
				break;
			}
		}
		printf(bz?"Set %d is not immediately decodable\n":"Set %d is immediately decodable\n",++cnt);
		freetree(root);
	}
	return 0;
}


你可能感兴趣的:(HDOJ 1305 Immediate Decodability (字典树判断是否存在子串))