HDU 1102:Constructing Roads【Kruskal & Prim】

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17214    Accepted Submission(s): 6538


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.
 

Sample Input
   
   
   
   
3 0 990 692 990 0 179 692 179 0 1 1 2
Sample Output
      
      
      
      
179
 
AC-code:
【Kruskal】
#include<cstdio>
#include<algorithm>
using namespace std;
int per[105];

void pre()
{
	for(int i=0;i<105;i++)
		per[i]=i;
}

struct node
{
	int b,e,len;
}s[5051];

bool cmp(node a,node c)
{
	return a.len<c.len;
}

int find(int a)
{
	return a==per[a]?a:find(per[a]);
}

int main()
{
	int n,i,j,q,x,y;
	while(~scanf("%d",&n))
	{
		pre();
		int u=0;	
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&x);
				if(j<=i)	continue;
				s[u].b=i;
				s[u].e=j;
				s[u++].len=x;
			}
		scanf("%d",&q);
		while(q--)
		{
			scanf("%d%d",&x,&y);
			if(find(x)!=find(y))
				per[find(x)]=find(y);
		}
		sort(s,s+u,cmp);
		int sum=0;
		for(i=0;i<u;i++)
		{
			if(find(s[i].b)!=find(s[i].e))
			{
				int fx=find(s[i].b);
				int fy=find(s[i].e);
				per[fx]=fy;
				sum+=s[i].len;
			}	
		}
		printf("%d\n",sum);
	}
	return 0;
}
 
【Prim】
#include<cstdio>
#include<cstring>
#define max 0x3f3f3f3f
int s[105][105],n;
void prim()
{
	int ans=0,min,k,i,j,vis[105],dis[105];
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
		dis[i]=s[1][i];
	dis[1]=0;
	vis[1]=1;
	for(j=1;j<n;j++)
	{
		min=max;
		for(i=1;i<=n;i++)
			if(!vis[i]&&dis[i]<min)
			{
				k=i;
				min=dis[i];
			}
		vis[k]=1;
		for(i=1;i<=n;i++)
			if(!vis[i]&&dis[i]>s[k][i])
				dis[i]=s[k][i];
	 } 
	 for(i=2;i<=n;i++)
	 	ans+=dis[i];
	 printf("%d\n",ans);
}
int main()
{
	int i,j,t,a,b;
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;i++)
			for(j=i;j<=n;j++)
				s[i][j]=s[j][i]=max;
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
			{
				scanf("%d",&s[i][j]);
				s[j][i]=s[i][j];
			}	
		scanf("%d",&t); 
		while(t--)
		{
			scanf("%d%d",&a,&b);
			s[a][b]=s[b][a]=0;
		}
		prim();
	}
	return 0;
}


你可能感兴趣的:(最小生成树,图论,HDU,kruskal,Prim)