HDU 4324:Triangle LOVE【拓扑排序】

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3692    Accepted Submission(s): 1455


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
   
   
   
   
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
   
   
   
   
Case #1: Yes Case #2: No
 

首先要理解题意~~~判断是否有成环的~~若有则输出Yes,木有则输出No~~

AC-code:

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int n,map[2010][2010],ind[2010];
char str[2010];
void topo()
{
	int i,top,k=0;
	queue<int>q;
	for(i=0;i<n;i++)
		if(!ind[i])
			q.push(i);
	while(!q.empty())
	{
		top=q.front();
		q.pop();
		ind[top]=-1;
		k++;
		for(i=0;i<n;i++)
		{
			if(map[top][i])
				ind[i]--;
			if(ind[i]==0)
				q.push(i);
		}	
	}
	if(k==n)
		printf("No\n");
	else
		printf("Yes\n");
}
int main()
{
	int t,k,i,j;
	scanf("%d",&t);
	for(k=1;k<=t;k++)
	{
		memset(map,0,sizeof(map));
		memset(ind,0,sizeof(ind));
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%s",str);
			for(j=0;j<n;j++)
			{
				map[i][j]=str[j]-'0';
				if(map[i][j])
					ind[j]++;
			}
		}
		printf("Case #%d: ",k);
		topo();
	}
	return 0;
}



 

你可能感兴趣的:(排序,拓扑,图论,HDU)