poj 2262 Goldbach's Conjecture -- 筛法求素数打表

Goldbach's Conjecture
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 42632   Accepted: 16314

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37

利用筛法先把1e6内所有的素数做上标记,0表示为素数,然后遍历到flag[i]==0&&flag[n-i]==0输出即可

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
const int N = 1E6+5; 
int flag[N];
void prime(){
	int i,j;
	memset(flag,0,sizeof(flag));
	flag[0]=1;
	flag[1]=1;
	for(i=2;i<=1e6;i++){
		if(!flag[i]){
			for(j=i*2;j<=1e6;j=j+i){
				flag[j]=1;
			}
		}
		
	}
}
int main(){
	int n,i,j;
	prime();
	while(~scanf("%d",&n)){
		if(n==0)
			break;
		for(i=2;i<=n/2+1;i++){
			if(!flag[i]&&!flag[n-i]){
				break;
			}
		}
		printf("%d = %d + %d\n",n,i,n-i);
	}
	return 0;
}


你可能感兴趣的:(poj,筛法求素数)