HDOJ 1019 Least Common Multiple(最小公倍最大公约)

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 38281    Accepted Submission(s): 14413


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

Sample Input
   
   
   
   
2 3 5 7 15 6 4 10296 936 1287 792 1
 

Sample Output
   
   
   
   
105 10296
 

Source
East Central North America 2003, Practice
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1005  1008  1061  1049  1108

#include<stdio.h>

int LCM(int a,int b)
{
	if(b==0)return a;
	else 
		return LCM(b,a%b);
}
int main(){
	int n,m,i,a,b;
	scanf("%d",&n);
	while(n--){
		scanf("%d%d",&m,&a);
		for(i=1;i<m;i++)
        {
            scanf("%d",&b);
            a=a/LCM(a,b)*b;//最小公倍数等于两个数的乘积除以最大公约数 
        }
        printf("%d\n",a);
	}
	return 0;
}


 

你可能感兴趣的:(hdoj)