Max Sum (HD_1003) 基础DP

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 198840    Accepted Submission(s): 46488


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
   
   
   
   
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
   
   
   
   
Case 1: 14 1 4 Case 2: 7 1 6
 

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003

题目描述:求最大子序列和

#include"iostream"
#include"cstdio"
using namespace std;
int dp[100005];
int star[100005];
int a[100005];
int main()
{
	int T;
	scanf("%d",&T);
	for(int k=1;k<=T;k++){
		int n;
		scanf("%d",&n);
		for(int i=1;i<=n;i++){
			star[i]=0;
			scanf("%d",&a[i]);
		}
		dp[0]=0;star[0]=1;
		int s=1,e=1,mmax=-0x7fffffff;
		for(int i=1;i<=n;i++){
			if(dp[i-1]+a[i]<a[i]){
				dp[i]=a[i];
				star[i]=i;
			}
			else{
				dp[i]=a[i]+dp[i-1];
				star[i]=star[i-1];
			}
			if(dp[i]>mmax){
				mmax=dp[i];
				e=i;s=star[i];
			}
		}
		printf("Case %d:\n%d %d %d\n",k,mmax,s,e);
		if(k!=T) printf("\n");
	}
 } 


你可能感兴趣的:(C++,dp,杭电)