杭电ACM 1001

Sum Problem

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 406156    Accepted Submission(s): 102002


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
   
   
   
   
1 100
 

Sample Output
   
   
   
   
1

5050

#include<iostream>
using namespace std;

int main(){
    int a;
    while(cin>>a){
        if(0==a%2)///防止溢出
          cout<<(a/2*(a+1))<<endl<<endl;
        else
          cout<<(a+1)/2*a<<endl<<endl;
    }
    return 0;
}


你可能感兴趣的:(ACM,杭电)