HDU - 4825 Xor Sum 字典树 + 二进制匹配

HDU - 4825
Xor Sum
Time Limit: 1000MS   Memory Limit: 132768KB   64bit IO Format: %I64d & %I64u

Submit Status

Description

Zeus 和 Prometheus 做了一个游戏,Prometheus 给 Zeus 一个集合,集合中包含了N个正整数,随后 Prometheus 将向 Zeus 发起M次询问,每次询问中包含一个正整数 S ,之后 Zeus 需要在集合当中找出一个正整数 K ,使得 K 与 S 的异或结果最大。Prometheus 为了让 Zeus 看到人类的伟大,随即同意 Zeus 可以向人类求助。你能证明人类的智慧么? 
 

Input

输入包含若干组测试数据,每组测试数据包含若干行。 
输入的第一行是一个整数T(T < 10),表示共有T组数据。 
每组数据的第一行输入两个正整数N,M(<1=N,M<=100000),接下来一行,包含N个正整数,代表 Zeus 的获得的集合,之后M行,每行一个正整数S,代表 Prometheus 询问的正整数。所有正整数均不超过2^32。
 

Output

对于每组数据,首先需要输出单独一行”Case #?:”,其中问号处应填入当前的数据组数,组数从1开始计算。 
对于每个询问,输出一个正整数K,使得K与S异或值最大。
 

Sample Input

         
         
         
         
2 3 2 3 4 5 1 5 4 1 4 6 5 6 3
 

Sample Output

         
         
         
         
Case #1: 4 3 Case #2: 4
先说明,由于是位运算(异或),先将其装换为二进制
比如
3 ->
8 7 6 5 4 3 2 1
0 0 0 0 0 0 1 1
那么先将他构成一个长度为32位的字典树中串
然后他是要求异或最大,1 ^ 1 = 0, 1 ^ 0 = 1,证明只有当他们不想等的时候才有可能最大
如此,从最高位32位开始往下进行比较,如果存在不想等的则一定取相反的,即如果匹配串的该位为1,那么原串的该位要为0
如果匹配串的该位为0,原串就要取1,如果原串没有1或者0可以取,那么只能取0或者1了
/*
Author: 2486
Memory: 25848 KB		Time: 452 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <vector>
#include <string>
#include <iostream>
#include <queue>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x3f3f3f3f;
const int MAXN = 10000000 + 5;
struct node {
    int next[2];
    LL d;
    void init() {
        d = -1;
        memset(next, -1, sizeof(next));
    }
} L[MAXN];

int tot, T, N, M;
LL tin, x;

void add(LL num) {
    int now = 0;
    LL ans = tin;
    while(ans > 0) {
        int tmp = ans & num;
        if(tmp > 0)tmp = 1;//因为该位存在与为1的话,tmp是大于等于1的
        int next = L[now].next[tmp];
        if(next == -1) {
            next = ++ tot;
            L[next].init();
            L[now].next[tmp] = next;
        }
        now = next;
        ans >>= 1;
    }
    L[now].d = num;
}

LL query(LL num) {
    int now  = 0, next;
    LL ans = tin;
    while(ans > 0) {
        int tmp = ans & num;
        if(tmp > 0)tmp = 1;
        if(L[now].next[!tmp] == -1) {//如果不存在相反的,则取不相反的
            next = L[now].next[tmp];
        } else {
            next = L[now].next[!tmp];//如果存在相反的,则一定取相反的,这是一个贪心策略
        }
        now = next;
        ans >>= 1;
    }
    return L[now].d;
}

void init() {
    tin = 1;
    for(int i = 0 ; i < 32; i ++) {
        tin <<= 1;
    }
}

int main() {
    init();
    int t = 1;
    //freopen("D://imput.txt","r",stdin);
    scanf("%d", &T);
    while(T --) {
        tot = 0;
        L[0].init();
        scanf("%d%d", &N, &M);
        for(int i = 0; i < N; i ++) {
            scanf("%I64d", &x);
            add(x);
        }
        printf("Case #%d:\n", t ++);
        for(int i = 0 ; i < M; i ++) {
            scanf("%I64d", &x);
            printf("%I64d\n", query(x));
        }
    }
    return 0;
}


你可能感兴趣的:(HDU - 4825 Xor Sum 字典树 + 二进制匹配)